Конференция работает на сервере Netberg

Radeon.ru

Конференция Radeon.ru

Страница 38 из 38 [ Сообщений: 1500 ]  Версия для печати [+] На страницу Пред.  1 ... 34, 35, 36, 37, 38
Показать сообщения за  Поле сортировки  

Почитай что там пишут создатели убунты и тебе кое-что станет ясно


Да мне и так все ясно: этот restricted-modules придуман для идиотов, которые пытаются впихнуть в систему новый драйвер, предварительно не удалив старого (заставлять такого рода "пользователей" редактировать конфигурационные файлы — все равно что давать заряженное ружье обезьяне). А когда старый драйвер все-таки удален, или его и не было (свежая установка), то система и запрещает тот модуль, который сумеет найти — то есть, единственный и нужный. В общем, от лукавого все это...
Но тебе, раз ты все равно ставишь драйвер из репов, эти заморочки сейчас без разницы (запрещать ничего не нужно). Тут другое интересно: согласно выводу lsmod модуль fglrx у тебя загружен (правда, не работает), а согласно логам xorg грузится radeon, а fglrx даже не упоминается. Неувязочка, однако.


Почитай что там пишут создатели убунты и тебе кое-что станет ясно

Да мне и так все ясно: этот restricted-modules придуман для идиотов, которые пытаются впихнуть в систему новый драйвер, предварительно не удалив старого (заставлять такого рода "пользователей" редактировать конфигурационные файлы — все равно что давать заряженное ружье обезьяне). А когда старый драйвер все-таки удален, или его и не было (свежая установка), то система и запрещает тот модуль, который сумеет найти — то есть, единственный и нужный. В общем, от лукавого все это...


Это пакетный дистр. Логичней запретить один старый драйвер, чем сносить весь огромный пакет с кучей рестриктед дров в нем с последующим отвалом половины оборудования.

Но тебе, раз ты все равно ставишь драйвер из репов, эти заморочки сейчас без разницы (запрещать ничего не нужно). Тут другое интересно: согласно выводу lsmod модуль fglrx у тебя загружен (правда, не работает), а согласно логам xorg грузится radeon, а fglrx даже не упоминается. Неувязочка, однако.

Однако, ты провидец :) Об этом я как раз писал 5 постов назад :) Я сам силюсь понять как система может грузить один драйвер, когда в конфиге прописан совершенно другой...

Однако, ты провидец Об этом я как раз писал 5 постов назад


Допустим, я помню, что ты писал пять постов назад. И язвить умею тоже. Но пока что пытаюсь разобраться и помочь, ежели что... Проблема весьма интересная. И тому, кто ее решит, миллионы убунтоидов по всему миру будут пожизненно возносить хвалы. Однако, у меня не было времени на длинный пост, и я ограничился короткой констатацией. Да и прежде чем что-то изобретать, имеет смысл попробовать то, что уже было изобретено. Например, упомянутому выше товарисчу завести драйвер помогло похеривание треклятых restricted-modules, а, скажем, у меня в федоре драйвер отказывался заводиться до тех пор, пока я не создал некий симлинк. В убунте, вроде бы, тоже надо создавать симлинк. Ты его создавал?


Я сам силюсь понять как система может грузить один драйвер, когда в конфиге прописан совершенно другой... 


Проблема не в том, как она, негодная, может, а в том, что она ничего не грузит: модуль radeon в выводе lsmod отсутствует, то есть, не загружается. А flgrx не упоминается в логах. Или логи какие-то левые, или уж я не знаю. Ты говорил, 2D работает. А что возвращается в консоли при запуске glxinfo/flgrxinfo? Какие ошибки выдают gears/flgrxgears?


Однако, ты провидец Об этом я как раз писал 5 постов назад

а, скажем, у меня в федоре драйвер отказывался заводиться до тех пор, пока я не создал некий симлинк. В убунте, вроде бы, тоже надо создавать симлинк. Ты его создавал?


Федора — не убунта.. "Некий" симлинк я не создавал, да и не нужен он в ней.


Я сам силюсь понять как система может грузить один драйвер, когда в конфиге прописан совершенно другой...


Проблема не в том, как она, негодная, может, а в том, что она ничего не грузит: модуль radeon в выводе lsmod отсутствует, то есть, не загружается. А flgrx не упоминается в логах. Или логи какие-то левые, или уж я не знаю. Ты говорил, 2D работает. А что возвращается в консоли при запуске glxinfo/flgrxinfo? Какие ошибки выдают gears/flgrxgears?


Там странная ситуация, поясняю — загружаюсь с дефолтным xorg.conf (vesa вроде) — иксы есть, 3д нету само собой. Драйвер fglrx из репов установлен, но не включен в конфиге. Прописываю в xorg.conf драйвер fglrx, делаю aticonfig --initial и перезапускаю иксы — графика есть, 2д, и в логе иксов написано про fglrx (кину позже, сейчас не дома), Fglrxinfo выдает mesa. А fglrx_gears выдает seg.fault, но 2д вроде работает. Делаю ребут ничего не меняя — и все, черный экран, а лог иксов левый... Т.е. на этапе начальной загрузки система начинает жить какой-то своей интимной жизнью и с дровами все идет кувырком...
убунту я ставил себе ненадолго – на пару дней месяца 4 назад. С официального сайта скачал 700мб Live CD — вообщем загрузился с него – и там еще была возможность – установить на жесткий диск – ну чтобы пользоваться не как Live CD а чтобы установлена была операционная систему – эта убунта докачала необходимые пакеты из инета и установилась.
Видеокарта у меня была HD2600XT или X700Pro — не помню уже – так вот – убунта когда загрузилась после установки — сама предложила скачать какой то модуль или пакет типа с драйвером для видеокарты – я согласился и она скачала – все нормально работало...
Я даже поиграл в Quake 4 и Doom 3 для Linux...
Вот это я хорошо помню что драйвер обычный radeon который .run я не ставил – убунта сама предложила скачать драйвер – какой то пакет или модуль и поставила.


дистрибутив новый какой то был – с сайта официального я скачивал.
Вообще убунта я как то не ставил себе надолго. Мне вот нравятся fedora 8 и Mandriva 2008 – сейчас у меня снова Mandriva 2008.

Ну вообщем то я не удивился что убунта сама предложила установить пакет с проприетарным драйвером — Mandriva тоже ведь предлагает поставить драйвер – только .run а убунту какой то свой помоему модуль ставила – не .run
Ну это я к слову написал :shuffle:
Да. В убунте есть своя приблуда для проприетарных дров — можно самому указать какие дрова заюзать (не только для видяхи) — и оно и по идее само скачает и установит. Этот способ я пробовал первым :) История была та же самая.
neuro
ну тогда я думаю что у вас несовместимость какая то на уровне железа. Потому что обычно нормально на всех видеокартах ставится драйвер.
у меня у самого на видеокартах ATI Radeon x700PRO и HD2600XT и в убунта и в fedora 8 и Mandriva 2008 работало все сразу — либо сама операционка предлагала поставить драйвер, либо как в fedora 8 — скачивал официальный драйвер .run и ставил его ( в fedora нужно было только отключить систему безопасности SELinux — иначе она мешает нормально поставиться драйверу ) . Не должно быть вообще проблем если только у вас видеокарта не с чипом RIALTO.

кстати, у вас видеокарта ATI Radeon x700 случайно не AGP ?
потому что у всех были проблеммы с видеокартами с чипом RIALTO ( если карта современная под PCI-express — то чип RIALTO как переходник для работы с шиной AGP )

Я так понял что с RIALTO ни у кого нормально видеокарты и не заработали..
neuro

в ядре отключите фрейм буфер.

ну тогда я думаю что у вас несовместимость какая то на уровне железа.
х1650 agp, но люди вот отписываются, что у них все работает с такими видяхами...

neuro
в ядре отключите фрейм буфер.

Плз подробнее, для простых смертных.
neuro
Ну так если у вас с RIALTO видеокарта в этом и проблема ..
Да, я помню кто-то писал что у него заработала карточка такая – но еще неизвестно что он для этого сделал...
А у скольких людей она нормально не заработала..
Например Mandriva 2008 она если узнает карточку – то при установке предлагает установить проприетарные драйверы – у меня так было с карточками PCI-express x700pro и HD2600XT
, а у моего друга видеокарта radeon 1950 Pro AGP — так эта Mandriva 2008 ему даже не предлагала установить проприетарный драйвер, что значит, Mandriva 2008 даже не узнала карточку.
Походу с RIALTO не узнает видеокарту из за этого чипа. Во всяком случае мне так кажется, точно конечно сказать не могу.
И очень у многих в том числе на этом форуме были проблемы именно с RIALTO видеокартами с этим чипом.
Иначе я например никак не могу объяснить почему проблема – ведь ставится элементарно драйвер официальный .run
после того как драйвер поставился нужно только набрать в консоли
aticonfig --initial
(именно так с двумя тире ) и все – это пропишет секцию frglx в файл xorg.conf
и все больше делать вообще ничего не надо!
Ну вобщем повозитесь – может добьетесь что заработает драйвер. Но это видимо будет уже не очень просто.
Не может быть действительно можно добиться чтобы заработал драйвер – но не очень просто это будет.
Лучше брать самый новый драйвер – или попробовать с разными драйверами лучше всего.
То есть более новую версию, если не получится то более старую попробовать.
Вообще тут писали что проблему с видеокартами с чипом RIALTO решили в драйвере catalyst 8.4 помоему и боле е поздних если я ничего не путаю.
Но это проверять надо – решили ее или нет – я лично не проверял.

neuro
Ну так если у вас с RIALTO видеокарта в этом и проблема ..

Спасибо, конечно, но.. Слов много, пользы мало.

Федора — не убунта..

Однако, тоже линукс. Не так уж сильно все эти линуксы друг от друга отличаются...
Ты б хоть поподробннее написал, что там у тебя ошибочно сегментируется... А вообще, запусти fgl_glxgears с опцией -fbo (хохмы ради), а также проделай
fgl_glxgears -v
и посмотри, что скажет.


Да, я помню кто-то писал что у него заработала карточка такая – но еще неизвестно что он для этого сделал...

chslava, это я писал, что у меня заработала "карточка такая". Для этого я — страшно подумать — установил драйвер. И все...
exodi
Понятно. Но вообще я еще почитал гугл на эту тему – у кого как, не у всех вообщем заработала такая карточка – AGP версия PCI-express видеокарты.
Впринципе это логично, так как насколько я знаю даже в windows были какие то проблемы с такими картами – что там специальный драйвер даже скачивать нужно было.
вот для интереса цитаты с других форумов:
(Первая фраза правда про AGP HD2600 и AGP HD3xx )

«В том-то и дело, что PCI-E. В проприетарном драйвере сломана поддержка AGP.
Автору ждать выхода открытого драйвера или менять видеокарту. А лучше материнку.»
http://linuxforum.ru/index.php?showtopi ... linearplus

«ATI отказалась от поддержки AGP, вот и весь ответ... А подгонку дров отдали на откуп производителям видюх, хотя формально ведь и чипы и мосты Rialto производят они сами... Как следствие — в Linux эти карточки на AGP завести не удасться...»
http://forum.ixbt.com/topic.cgi?id=10:54550-8


а вот и форум ubuntu на эту тему с аналогичными проблемами:
http://forum.ubuntu.ru/index.php?topic=32884.msg235553

да я просто для информации написал свои посты. Может конечно все и не так. Просто как то странно что с RIALTO у многих проблемы возникают. Установка драйвера ведь очень простая.
В Release notes в supported карточках указано: "X1600 series" и никаких замечаний насчет AGP не замечено. Хотя насчет того, что ATI конкретно испортились — согласен, душок нехороший уже давно витает... Но я категорически против советов типа "хвост будем рубить с головы" (т.е. купить новую видяху, новую материнку, выкинуть комп и тд)...
neuro

В ядре есть DRI-драйвера, если ядро не компилить могут загружатся и
тем самым блокировать загрузку fglrx.
Тут есть счастливые обладатели мобильных карточек ati? Желательно mobility radeon 2600. Скажите, что у вас aticonfig --lsp выдает? Сдается мне это только у моего ноутбука проблемы с энергосбережением...
Смотрел я на новость:

http://www.radeon2.ru/?select=more&f=2008_09&new=54.

Картинки там хорошие, но есть один НЕ ЯСНЫЙ ньюанс. Когда, <self-censored>, нормальные дрова на 3870Х2 появятся??? Hybrid Crossfire вроде как уже с августа должно быть, однако, правда, для винды :(
кто нибудь знает в 8.9 добавят поддержку ксорга 7.4? а то хочу поставить федору 9, а париться с даунгрэйдом ксорга до 7.3 неохота :)
А что, обещают?
Поддержку CrossFireX, помнится, обещали еще в 8.6, а появилась она только в 8.8 (и то не для всех).
А уж если даже не обещают...
дык я и спрашиваю, может хоть обесчали? :)
Новая тема    Ответить  [ Сообщений: 1500 ]  На страницу Пред.  1 ... 34, 35, 36, 37, 38


Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot] и гости: 1


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  

Удалить cookies конференции

Пишите нам | Radeon.ru