Конференция работает на сервере Netberg

Radeon.ru

Конференция Radeon.ru

Страница 1 из 2 [ Сообщений: 47 ]  Версия для печати [+] На страницу 1, 2  След.
Показать сообщения за  Поле сортировки  
Поставил тут по случаю патч 1.3 на вольфа — первое,что бросилось в глаза — перформенс упал почти в 5(!) раз Изображение
При детальном рассмотрении проблемы выяснилось следующее:
Ещё когда ставил патч 1.01 пробовал включать труформ,отличий никаких не нашел — вероятно,он просто не работал.Тут же решил посмотреть поближе на людей в игре — труформ заработал!!! Ботинки и прочие бывшие угловатыми места стали круглыми,волосы на голове у баб тоже перестали быть пятиугольными... Но Изображение Изображение
Неужели такой ценой... ФПС в некоторых местах стал 12 кадров... На П4@1900 МГц и радеон 8500...
Пробовал переключать режимы качества труформа — при наихудшем качестве падение произвоодительности,по сравнению с отключенным труформом почти в 2 раза Изображение
И причем это иной раз в местах,где нет в фокусе ни движущегося ничего,ни людей,на которых виден этот самый труформ... Просто стены и шкафы.А ещё при включении труформа сильно возрастают рывки при движении,причем по одному и тому же коридору идешь туда и обратно — в одну сторону просто жутко дергается,в другую всё ОК...
Похоже опять не встретились дрова 6043 и реализаторы ОГЛ в вульфе... Изображение
Может кто потестит с другими дровами?
BoyRadeon
Чё ни у кого Вульфа нет что-ли
BoyRadeon
попробуй разные степени тессселяции.
в 5 раз это небось на макс. уровне.
Да,это на максимальной тесселяции... Но ведь в демке с дельфином... Там конечно,нет указателя ФПС,но он явно больше 12 кадров и визуально скорость этой демки не зависит от качества тесселяции. Похоже опять софтовые проблемы,пробовал крутить АГП — апертуру и вкл/откл АГП текстуринг в настройках директХ... Рывки убираются в одних местах и возникают в других! Проверял несколько раз на разных уровнях. А в серьезном сэме на 6043 как дела с труформом и насколько он поедает перформенс?
У меня его сейчас нет — проверить никак.
Уж очень неохота проверять со всеми дровами — обломно их сносить и ставить по всем правилам...
Но сдвиги есть — труформ работает,игра при этом не глючит и раздутых вещей нету.Отрисовка классная...Вот только бы побыстрее немного...
Изображение
Но ведь в демке с дельфином... Там конечно,нет указателя ФПС,но он явно больше 12 кадров и визуально скорость этой демки
так то демка.
Да,с сэмом дела несколько получше.... Только во в вульфе труформ явно только на людях и технике — на ящиках и шкафах его нет — сколько ни сравнивал,а отличий не нашел.
А анизотропка х16 естессно у меня тоже включена — похоже труформ с анизотропкой плохо дружит — пробовал отключать —
разница ощутимая весьма. Хотя без труформа ее включение практически не сказывается на производительности.
И ещё совершенно непонятно — почему труформ грузит внешнюю шину карты??? Ведь она по идее делает его внутри,аппаратно. Ведь рывки при движении — явная недостаточная прокачка через АГП... Или я неправ?
BoyRadeon
Хотел тоже создать тему по этому поводу вчера, но ты меня опередил! Изображение
Я потестил сегодня в Win98se на дровах 7206!
Ну что можно сказать? IMHO плохо они его реализовали в RtCW! И это мягко сказано!
Вот команды:
r_ati_truform_pointmode (LINEAR, CUBIC)
r_ati_truform_normalmode (LINEAR, QUADRATIC)
r_ati_truform_tess 0-3 (0-no, 1-good, 2-better, 3-best; можно поставить из меню игры)
r_ati_truform_tess 0-7 (0-no, 1-good, 2-better, 3-best;47 можно поставить из консоли!
Прошу вас обратить внимание на цифру 7 !
Видимо Truform работает на max только если поставить цифру 7!!! Это можно проследить по левому верхнему краю обоймы автомата (оружие N3), чуть выше пальцев руки!
Так вот, поставил N7, и при этом в комнате где обычно с truform'ом N3 (best) было 60-70 fps(кстати ВПОЛНЕ играбельным), чудесным образом становится 30-40fps, а иногда и меньше!!!!!!!!!!!!!! Изображение + непонятные перевопложения обоймы автомата при перезарядке (оружие N3) + неприятные рывки не поворотах + текстуры теней/крови на полу изменяются криво!!!! Изображение
А визуальной разницы между 3 и 7 почти нет! Изображение

Короче потестил несколько минут и вышел!
Вывод один: Реализовали, но так погано! Изображение
Так реализовать можно было и в версии 1.0 ! Одним словом я ожидал от них большего! Изображение
Хотя, возможно я сужу их слишком строго! При N3 играть можно без проблем (почти)!
Это несомненно + в копилку truformsupported игр, хотя и не самый удачный!
В том же Half-Life/Opposing Force/Blue Shift/CS Truform реализован НА ПОРЯДОК ЛУЧШЕ!!! Изображение <P class=ch>[Исправлено: Cybekk : 19-03-2002 06:55 PM]</P>
Cybekk
А анизотропка у тебя была включена при тестировании и какая? И какое разрешение?
Я умудрился в одном уровне найти места,где у меня на 1024 и
анизо х16 труформ 3 было 12 ФПС!
Похоже на вин ХР дело несколько хуже или дрова 6043...

Какими командами управляется труформ в халфлайфе/оппозинге и какая версия игры должна быть для этого?
Сегодня тоже проверил, действительно при N3, вполне, прилично всё бегает, причём анизонтропка включена 128x.
На счёт того, что Truform не дружит с анизонтропкой так это врядли. В том же Serious Sam SE играл с Truform+aniso 128x и всё ОК! Совсем забыл, дрова 6052
<P class=ch>[Исправлено: MRover : 20-03-2002 01:43 PM]</P>
BoyRadeon
А анизотропка у тебя была включена при тестировании и какая? И какое разрешение?
Анизотропка у меня включена всегда! Стоит по-моему 16x
Разрешение 1024x768x32+все опции в игре на max, Truform N3!
Игра идет просто ИДЕАЛЬНО с такими настройками!
Но если поставить Truform N7, то всё сразу меняется в худшую сторону! Изображение
Непонятно что изменяется с включением Truform N7, но fps при нём проседает с диком силой! Этот вопрос хотелось бы задать разработчикам!

<I>Я умудрился в одном уровне найти места,где у меня на 1024 и
анизо х16 труформ 3 было 12 ФПС!</I>
Изображение 12 fps это уже не играбельно! Изображение
Кинь мне save из того места, или просто скажи название карты/уровня! Я у себя проверю!

Какими командами управляется труформ в халфлайфе/оппозинге и какая версия игры должна быть для этого?
Truform в HL/OF/BS/CS1.3 РАБОТАЕТ ТОЛЬКО В OpenGL, в D3D можно даже не пробовать!
В обычном HL я тестил в версии 1.1.0.8 (последний patch — 78Mb, если ставить на сырой HL 1.0)
В Opposing Force я тестил в 1.1.0.6 (этот далеко не последний, сейчас уже вышел 1.1.0.8 для OpFor, но и на нём у меня Truform отлично работает!)
В Counter-Strike 1.3 он тоже работает, но TruForm задействован только на моделях оружия/рук! (скоро появится CS 1.4 — посмотрим какая там будет ситуация)
Вот команды:
ati_npatch 0-1 (включение Truform, 0 — выкл, 1- вкл.)
ati_subdiv 0-4 (уровни тесселяции)<P class=ch>[Исправлено: Cybekk : 20-03-2002 03:49 PM]</P><P class=ch>[Исправлено: Cybekk : 20-03-2002 03:50 PM]</P>
У меня проседает,даже если поставить на бест из меню игры — а дальше ничего не меняется — при установке на 7 — фпс не меняется.И рывки появляются — без труформа их вообще нет!
Попробую сегодня на HL/OF.
карта называется кажись chateau.bsp
Надо попробовать запустить ее без монстров и придти в то место,посмотреть на ФПС. В общем,на уровне фпс нормальный,есть "проблемные" места,причем на вид ничем не примечательные. Сегодня ещё потещу — напишу. Засейвлюсь прямо в этом месте и скину тебе сейв.
Сейчас пришел домой и еще потестил немного!
Так вот! Собрал немало информации для обзора/небольшой статьи по поводу реализации Truform в RtCW! Правда времени её делать — 0! Изображение
(2 Ruslan73: Могу выслать скрины и некоторые мысли по этому поводу или можем связаться по icq/mail/телефон, что предпочтительнее Изображение !)
Так вот полазил я в игре и посмотрел что, как и где меняется!
Вывод: Лучшее соотношение качество/производительность с применением Truform в RtCW — Truform N2 (better)!
Это можно легко проследить по гранате (та, которая с деревянной ручкой)!
Когда уровень тесселяции поставить N3 (best) ручка гранаты начинает заостряться к вершине, что явно неправильно и является перебором!
А с N2 такого нет!
Правда еще один минус есть у всех номеров (1-7) — посмотрите на таймер динамита(не помню номер оружия, по-моему N5)! Даже при использовании Truform N1 (good), текстуры расползаются так, что таймера не видно на динамите!!! Изображение
Правда всё это можно увидеть только, если смотреть на truform-изменяющуюся model (убитый солдать например)!
Короче есть о чём написать в статье!

imho скоро в хороших обзорах игр еще помимо баллов за gameplay,graphics,sound и overall надо будет писать балл за качество реализации Truform'а в игре! Изображение
Cybekk
Ещё обрати внимание на станковый пулемёт, он явно неправильной формы, причём если с ним покруться, то в некоторых положениях он принимает нормальную форму!
Men попробуйте выставить использование памяти вольфом адекватно своим системам — по умолчанию 96 Мб что около 3/4 от 128 для 256Ьб ой системы соответственно 192Мб и так далее
Ключь в консоли: \com_hunkmegs 192
(пример для 256 рамы)
<P class=ch>[Исправлено: alrez : 21-03-2002 09:46 PM]</P>
alrez
Ключь в консоли: \com_hunkmegs 192
Это я всегда ставлю еще до первого запуска игры!
Этот мне ключ известен еще с Q3!
Cybekk
я за тебя просто рад : )
alrez
я за тебя просто рад
Спасибо!
Вчера потестил ещё — выяснил интересную вещь — во первых — на оружии труформа похоже нету — к примеру — раструб ракетницы — как был многоугольный так и остается,даже на труформ 7,да и ручка гранаты вроде как тоже не изменяется.
Во-вторых — при увеличении тесселяции выше 2 просто когда стоишь на месте в некоторых местах и ничего не двигается в игре вообще счетчик ФПС непрерывно быстро изменяется,причем иногда в два раза. Без труформа если стоять на месте он тоже стоит или прыгает макс. +/— 1 кадр.
Соответственно,при движении в таких местах возникают рывки,иногда весьма ощутимые(уже не играбельно).
Скачал патч к халве 78 мб — а то на моей версии труформ не включался (unknown command) cегодня поставлю,посмотрю на результаты.
BoyRadeon
Вчера потестил ещё — выяснил интересную вещь — во первых — на оружии труформа похоже нету — к примеру — раструб ракетницы — как был многоугольный так и остается,даже на труформ 7,да и ручка гранаты вроде как тоже не изменяется.
На некоторых видах оружия есть Truform, очень криво реализованный кстати!
(Про таймер на динамите я уже говорил! Изображение )
Скоро статья будет про это дело (и не только)!
Зато в халве труформ работает и неплохо,по крайней мере не жрет так кадры и никаких рывков.
BoyRadeon
Про Half-Life я уже говорил выше! С тобой полностью согласен! Там он реализован на 5 баллов! Изображение
BoyRadeon

>Зато в халве труформ работает и неплохо,по крайней мере не жрет так кадры и никаких рывков.\


Думаю это не потому-что он там как-то "по-особенному хорошо" реализован, а потому-что игра — СТАРЬЕ, летающее даже на TNT/V2 и "ополовинить" в ней fps, труформом, на такой мощной карте как R8500, можно без проблем, не потеряв играбельности при этом.
Cybekk
А в HL он только на 8500 идет?
У меня версия 1.1.0.7 и не знает этих команд "ati_*"
kef
А в HL он только на 8500 идет?
Не только! На всех остальных радеонах тоже должен идти! Но только в software!
У меня версия 1.1.0.7 и не знает этих команд "ati_*"
Проапгрейди до 1.1.0.8 и команды появятся! http://www.planethalflife.com/half-life/files/

p.s. Кто-то говорил, что надо ставить полный 1.1.0.8 patch (78Mb)! Только тогда Truform заработает!

<P class=ch>[Исправлено: Cybekk : 24-03-2002 02:39 PM]</P>
.<B>Кто-то говорил, что надо ставить полный 1.1.0.8 patch (78Mb)! Только тогда Truform заработает!
</B>
Да,пока я не поставил полный патч,у меня тоже не заработал
У меня видеокарта Radeon agp GeCube HD3850 512mb. Проблема в том что когда я запускаю Return To Castle Wolfenstein в меню он все заходит настройки все меняет но когда вхожу в игру, 1миссия где в тюрьме там виснет, потом вроде как работает потом начинаешь выходить из тюрьмы опять виснет и потом вылетает ошибка VPU... и повисает потом выхожу в Windows Xp (ctrl+alt+delete) и потом в виндовсе все тормозит(как будьто не поставлены дрова), ну когда компьютер перезагружаешь все нормально становится в виндовсе, но игра не работает так же. Подскажите что делать игра рабочая 100% потому что на NVIDIA 8600 идет. тут написали отключить Catalyst™ A.I не помогло
так вроде скоро новая версия выходит, вот в нее и поиграем!
Дак я хочу в старую :)
Чё не кто не знает ? у всех эта проблема.
Поставил новые дрова ваще намертво виснет, сразу в тюрьме(1миссия).

овердрайв разблокирован в ССС (может поможет )

что это ?
Перегрева нету 52% температура, игры все нормально идут GTA 4, Stalker чистое небо они же не виснут а тут блин Return to Castle Wolfenstein который на mx440 идет не идет. Видеокарта не разогнана в программе ваще не чё не настраивал. Написали что надо отключить Catalyst™ A.I не помогло
И на этом диске 7 Wolfenstein'ов и именно не идет Return to Castle Wolfenstein (а дополнения все идут может дальше такой же глюк не проходил) думал что фиговая версия проверил на другом компьютере (там NVIDIA) все работает без проблем
Ну не знаю версию от фаргуса (1.0) прошел недавно на ати 3650 вообще без проблем . Самое удивительное что вернувшись к игре через 4 или 5 лет (после первого прохождения) , сыграл с удовольствием.
Hrenogon
А truform работал?
frontier
Честно сказать впервые про него прочитал в этой теме , а как проверить ? Я играл на максе и разрешение 1280*1024 каких то ужосов особых не заметил с углами.

У меня видеокарта Radeon agp GeCube HD3850 512mb. Проблема в том что когда я запускаю Return To Castle Wolfenstein в меню он все заходит настройки все меняет но когда вхожу в игру, 1миссия где в тюрьме там виснет, потом вроде как работает потом начинаешь выходить из тюрьмы опять виснет и потом вылетает ошибка VPU... и повисает потом выхожу в Windows Xp (ctrl+alt+delete) и потом в виндовсе все тормозит(как будьто не поставлены дрова), ну когда компьютер перезагружаешь все нормально становится в виндовсе, но игра не работает так же. Подскажите что делать игра рабочая 100% потому что на NVIDIA 8600 идет. тут написали отключить Catalyst™ A.I не помогло


Посмотри здесь, должно помочь.
http://forum.radeon.ru/viewtopic.php?p=519287#p519287
народ помогите

при запуске выводится такое ( видеокарта xpress 1150)

Wolf 1.32 win-x86 May 1 2002
----- FS_Startup -----
Current search path:
C:\Program Files\Return to Castle Wolfenstein\main\sp_pak5.pk3 (967 files)
C:\Program Files\Return to Castle Wolfenstein\main\sp_pak4.pk3 (21 files)
C:\Program Files\Return to Castle Wolfenstein\main\sp_pak3.pk3 (14 files)
C:\Program Files\Return to Castle Wolfenstein\main\sp_pak2.pk3 (232 files)
C:\Program Files\Return to Castle Wolfenstein\main\sp_pak1.pk3 (1342 files)
C:\Program Files\Return to Castle Wolfenstein\main\pak0.pk3 (4775 files)
C:\Program Files\Return to Castle Wolfenstein/main

----------------------
7351 files in pk3 files
execing default.cfg
couldn't exec language.cfg
execing wolfconfig.cfg
execing autoexec.cfg
Hunk_Clear: reset the hunk ok
...detecting CPU, found AMD w/ 3DNow!
Bypassing CD checks
----- Client Initialization -----
Cmd_AddCommand: map_restart already defined
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
...initializing QGL
...calling LoadLibrary( 'C:\WINDOWS.2\system32\opengl32.dll' ): succeeded
...setting mode 8: 1280 1024 FS
...using colorsbits of 32
...calling CDS: failed, bad mode
...trying next higher resolution: failed, bad mode
...restoring display settings
...registered window class
...created window@3,22 (1286x1049)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 8 )
...53 PFDs found
...hardware acceleration found
...PIXELFORMAT 5 selected
...creating GL context: succeeded
...making context current: succeeded
...WARNING: fullscreen unavailable in this mode
...setting mode 8: 1280 1024 FS
...using colorsbits of 16
...calling CDS: failed, bad mode
...trying next higher resolution: failed, bad mode
...restoring display settings
...window already present, CreateWindowEx skipped
Initializing OpenGL driver
...WARNING: fullscreen unavailable in this mode
...shutting down QGL
...unloading OpenGL DLL
...assuming '3dfxvgl' is a standalone driver
...initializing QGL
...WARNING: missing Glide installation, assuming no 3Dfx available
...shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
GLW_StartOpenGL() — could not load OpenGL subsystem
Пишет, что не может задйствовать OpenGL
Вы драйверы на свою "видеокарту" ставили вообще?

Пишет, что не может задйствовать OpenGL
Вы драйверы на свою "видеокарту" ставили вообще?


издеваешься??

Driver Packaging Version 8.351-070302a1-047651C-Dell
Provider ATI Technologies Inc.
2D Driver Version 6.14.10.6677
2D Driver File Path System/CurrentControlSet/Control/Video/{41A65572-91D9-4103-80FF-2EFD0E759D8E}/0000
Direct3D Version 6.14.10.0487
OpenGL Version 6.14.10.6388
Catalyst® Control Center Version 2007.0306.2333.41984
AIW/VIVO WDM Driver Version 6.14.10.6238
AIW/VIVO WDM SP Driver Version 6.14.10.6238
Новая тема    Ответить  [ Сообщений: 47 ]  На страницу 1, 2  След.


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  

Удалить cookies конференции

Пишите нам | Radeon.ru